Many people have posted problems on the Adobe forums regarding applying the Adobe Acrobat Pro 9.3 update, where the update refuses to install stating that “the application has been modified since it was originally installed).  The workaround for most is to manually uninstall Acrobat, reinstall, then update.  This process can take over an hour and can be quite frustrating.

Again, due to the highly unlikely odds that this security vulnerability will actually affect any Mac users, I would say to skip the Acrobat Pro 9.3 update IF it refuses to install easily.  Adobe will likely figure out why the update sometimes refuses to install, and include a fix with a future Acrobat Pro 9.x update..