Adobe CS apps will give an error stating you need Java SE 6 runtime if you try to launch them on a Mac running OS X 10.8. This has been confirmed with Adobe CS4, CS5, CS5.5, and CS6.

This is a little confusing, as Apple and Java recommend that Mac users on OS X 10.8 run Java SE 7, and the system will disable the SE 6 runtime to prevent you from using the old version.

In order to resolve this, you will need to manually download the Java SE 6 installer from Adobe at http://support.apple.com/kb/DL1572 and run it. Adobe apps will not run until you complete this install.