Not Earth shattering news, but the recently released Firefox 17 has dropped support for OS X 10.5. It requires OS X 10.6.8+.