I’m listing this topic in both the workstation and server related sections, because Mac Servers are just as likely to have Promise RAIDs connected…

Mavericks has major problems with Promise Pegasus R4 and R6 RAIDs. If you have a Mac or Mac server with a Promise Pegasus R4 connected, do NOT update it to Mavericks. The typical symptom is that everything works for a while, a Mac workstation will crash when accessing the Promise, then the Promise will start intermittently unmounting itself or become completely unusable.

Promise has yet to acknowledge this problem, and it will likely take a firmware update from them in the future to address this.