If you have a Mac server running OS X 10.7 or 10.8, with the VPN service turned on and set to allow L2TP connections, upgrading the server to Mavericks and Server 3.0 will likely break your setup.

Apple has posted a Knowledgebase Article describing this, and their solution is to use PPTP instead for VPN connections. (Note: PPTP requires directory accounts)
http://support.apple.com/kb/TS5313

Those needing to restore L2TP VPN connections after upgrading have found a use-at-your-own-risk workaround of copying and replacing the /usr/sbin/raccoon directory from a OS X 10.8 server. For more info, see this Apple Discussion thread:
https://discussions.apple.com/thread/5471582