Apple has released a VPN Update for Server 3. This update is for Macs running Mavericks and the Server app, where the Server app has the VPN service enabled. It fixes a problem where users are not able to connect via L2TP.

This VPN update requires OS X 10.9.1 and either Server 3.0.1 or 3.0.2, plus also requires that the VPN service has been previously enabled.
http://support.apple.com/kb/HT6080