If you get an “invalid checksum” error when attempting to update to OS X 10.9.4, try downloading and applying the OS X 10.9.4 Combo Updater directly from Apple’s site. If you continue to receive the “invalid checksum” error when using the Combo Updater, go into /Library/Updates and trash the 10.9.4 Update that was originally downloaded, then try again.