Last month I reported that the OS X 10.10.2 Combo update would only run on OS X 10.10.0, and not OS X10.10.1 or 10.10.2. I mentioned this because reapplying the latest Combo updater is a commonly used Mac troubleshooting step, and I was concerned that Apple had changed things in Yosemite.

Fortunately Apple’s recent OS X 10.10.3 Combo update functions the way Combo updaters used to, and it can be run on OS 10.10.0, 10.10.1, 10.10.2, and 10.10.3.