The OS X 10.10.4 update includes an EFI Security Update, which addresses the firmware vulnerabilities dubbed Prince Harming and Dark Jedi, where the EFI is left unlocked/editable after most pre-2015 Mac models wake from sleep.

This EFI Security Update will not install if the Mac is booted into Safe boot mode. Some tech savvy people always boot their Macs into Safe boot mode before applying Apple updates, but in this case the OS X 10.10.4 update should only be applied while the Mac is booted normally.

These same EFI firmware vulnerabilities were also recently patched by Apple for OS X 10.8 and 10.9, via the Mac EFI Security Update 2015-001.