Yahoo made changes on June 15th, ending compatibly with some older Apple devices. To communicate with Yahoo Mail on an iOS device using the Mail app, you now must have iOS 5 or later. To communicate with Yahoo Contacts on a Mac using Address Book/Contacts, you now must have OS X 10.8 or later.