FileMaker has published a list of know issues with running Filemaker 14 under OS X 10.11. http://help.filemaker.com/app/answers/detail/a_id/15187/kw/el%20capitan

They also have stated that FileMaker 13 and older is untested and not supported with El Capitan. “While these earlier versions may install and run, you may encounter installation and stability issues for which there is no resolution.”