Apple just released an update for Server app 5 (aka OS X Server), taking it to version 5.1.7.   This update now requires OS X 10.11.6.

Prior to this update, Server app 5.x could be run on either OS X 10.10 or 10.11.  Because the most recent version now requires OS X 10.11.6:

  • Server app 5 can no longer be purchased in the Mac App Store on Macs running OS X 10.10.
  • If you have Server app 5.x installed on OS X 10.10, there is no way to re-download a copy of your purchased app from the Mac App Store without first updating to OS X 10.11.

As with any update to a Mac running the Server app, I recommend doing a full backup of the boot volume prior to updating the operating system or Server app itself.  Time after time I have seen these types of updates break things in major ways, and having a full backup allows for a quick and easy rollback, giving time to regroup and decide how to proceed.